Why not just ifnot? Same count of characters but an o instead of a possibly problematic single quote.
I think it’s just capitalizing on a trend to add n’t to otherwise noy contractions, to make them into contractions. Contractionn’ts, if you will
Yes… how is reducing exclamation marks a good thing when you do it by adding a
'
(not to be confused with,
´,
‘or
’`).Does this rely on the assumption that everyone uses a US QWERTY keyboard where
!
is slightly more inconvenient than typing'
?
array.whomst(element => element === needle)
What’s wrong with “else”
It’s not
ifn't
^This
OP raises a valid point
Cannot start a statement with else. One can with ifn’t. There is a new thing where we don’t branch (which is a separate discussion).
Or am I missing the joke…
if(condition) {#block never used} else {#actually do a thing}
Vs
ifn't(condition) {#actually do a thing}
Vs
if!(condition) {#actually do a thing}
vs
if (not condition) {#actually do a thing}
Please God let this be a humorous post that somehow does not also find a way to manage to come true…
I would have bought it if they said ifnot instead, it’s the same number of characters and wouldn’t require a major parser overhaul to support keywords with a ’ in the name.
Yeah, to be clear, I don’t like it, I don’t like it one bit:-P.
i mean, “unless” tends to be the usual term for an “if not” keyword in languages that implement such a thing
Which is awful and incredibly confusing. I hate ruby
totally agree; just saying that if it’s GOT to be something, that something should probably be unless… unless . . .
And Perl
And my axe!
I find that you need to choose carefully when to use it. Simple cases tend to be alright. Larger, more complex conditions shouldn’t touch it.
cap () {
}
nocap () {}
nocap(frfr){
}
ifn't(!valid)
halp?I believe that resolves the same as
ain’t!(!untrue)
ain’t (nothin)
I’m just hoping this paves the way to code with Southern dialect
iffun is == true iffun ain't == false
May I introduce you to the joys of #define and creating your own horrible sub language
That reminds me of an old paper about how to create a compilable C program out of old game ROMs. Decompile to assembly. Implement a bunch of
statements that implement all the ASM statements. Now compile it to a native binary on whatever platform.
Won’t likely be faster or more accurate than regular emulation methods, but it’s a neat idea considering that the source code on all this stuff was lost a long time ago.
aint (something) { somethingElse() }
;-;
I propose a new, more threatening kind of control flow.
do { /* something */ } or else { /* you don't want to find out */ }
You just made me a offer I can’t refuse. I go now to sleep with the fishes…
The better try-catch. More intuitive if you ask me.
do { /* something */ } do hast { /* something */ }
do { /* something */ } do hast { /* something */ } do hast mich { /* something */ }
It exists, kind of. Python has this construct
for item in iterable: ... else: ...
which always puzzles me, since it depends on a break statement execution. I always have to look it up when the else block is executed.
this is just a menacing try/catch!
Some C++ style guides suggest the following naming convention for functions that crash on any error
OpenFileOrDie()
PHP has the always wonderful (and perfectly functional) syntax of
logUserIn() or die();
Or Perl
Perl also has
unless()
for the very purpose in OP, which is a more sensible choice.Oh, and if you need to reinforce your belief that Perl is a mess, the single-quote character can be used as a package separator instead of “::”. This was set in the 90s when nobody was quite sure of the right syntax for package separators, so it borrowed “::” from C++ and the single quote from Ada (I think).
That means the
ifn't()
in OP can be interpreted as calling thet()
function on theifn
package.The “::” separator is vastly preferred, though. Single quotes run havoc on syntax highlighting text editors (since they can also be used for strings). About the only time I’ve seen it used is a joke module,
Acme::don't
.
Personally, I like to call catched exception variables
up
, so for a rethrow I canthrow up;
.Except rethrowing an exception in C# is just
throw;
, anything else is a crime against the person who reads your stacktraces.
It_would_be_a_shame_if(condition)
I can actually define this in TCL:
% proc ifn't {cond cmds} {if {!$cond} {uplevel $cmds}} % ifn't false {puts 12} 12 % ifn't true {puts 12} %
Python already has this.
die unless $keyword == “unless”;
I personally have a gut feeling of rejection for every language having the
unless
keyword. This is why I hardly know any PERL and Ruby for example.I have mixed feelings towards Kotlin’s
takeUnless
scope function (I nearly always usetakeIf
with a negated predicate) because my mind forgets the unless version exists.
I shan’t!
I’m struggling to understand if this is true or ifn’t true